Установка PHP 5.3.5 (FPM, Imagick, eaccelerator, memcache) на CentOS 5.5

Поступила заявочка на обновление php-5.2.14 до php-5.3.5, с сохранением всех существующих модулей. Причем обновить нужно на боевой машине, находящейся в продакшене. Операционная система CentOS 5.5, собственно как и везде (корпоративный стандарт, ничего не поделаешь). В стандартных репах лежит вообще какая-то доисторическая версия данного ПО, в EPEL`e - PHP-5.2.17, не люблю ставить софт из непроверенных источников, и тем более компилировать его ручками на таких машинах. Версия выбрана не случайно в php5.3 появилась какая-то полезная штука под названием PCRE, которой к сожалению нету в php5.2, а версии выложенные практически во всех сторонних репозиториях - php-5.3.3. Данная php версия по словам разработчиков содержит критическую уязвимость.

Решено: собираем свой пакет php для CentOS, или..

Продолжить чтение

Комментарии


Гость сказал:
>в EPEL`e - PHP-5.2.17, не люблю ставить софт из непроверенных источников

>в поисках наткнулся на хороший репозиторий REMI для CentOS 5.5

Т.е. EPEL стал "непроверенным источником", но при этом REMI это хороший репозиторий?

спасибо поржал :D

root сказал:
EPEL хороший репозиторий, кто же спорит. Но там как была версия php-5.2.17 так и лежит.
А в REMI всё своевременно обновляется. REMI используем в продакшене уже больше года. Самое главное правило - Отключить все остальные репы, иначе будет пипец. Система какая - ставлю нгинкс из CentALT, все остальное из REMI (php-fpm 5.3.8) - Работает!

ps: php-fpm 5.2.x нам не подходит для работы, потому как при наших нагрузках раз в сутки виснет, или просто вылетает. Господа, говорю из собственного опыта.

pps: Привет Вам в Питер, как у Вас погодка?

Вы должны войти, чтобы отправлять комментарии на этот сайт - пожалуйста, либо войдите, либо - если вы еще не зарегистрированы - [щелкните] здесь , чтобы зарегистрироваться