Релиз почтового сервера Postfix 2.8.0

Анонсирован релиз новой стабильной ветки почтового сервера Postfix - 2.8.0. В новой версии продолжена работа над улучшением кодовой базы, усовершенствованием документации и реализацией новых механизмов для противостояния таким сетевым угрозам, как спам.

Ключевые улучшения:

  • В состав стабильного релиза включен демон postscreen, выступающий в роли легковесного межсетевого экрана, предназначенного для первичного блокирования соединений от рассылающих спам зомби-машин. Postscreen поддерживает TLS и может вести лог отвергнутых соединений, адресов получателей и информации, передаваемой в заготовке "helo";
  • Поддержка основанных на DNS белых списков (ранее поддерживались только черные списки - DNSBL) и возможность выборочной блокировки через фильтрацию по маске ответов от DNSBL и DNSWL серверов. Управление белыми списками организовано через опцию permit_rhswl_client, а фильтрация организована через reject_rhsbl_client (например, можно указать "reject_rhsbl_client zen.spamhaus.org=127.0.0.[1..10]");
  • Возможность использования БД SQLite для хранения внутренних баз, таких как БД виртуальных пользователей, алиасы или списки доступа (в дополнение к таким типам хранилищ как btree, dbm и hash). Для подключения необходимо использовать опцию "sqlite:", формат данных определяется через опцию query (например, "query = SELECT forw_addr FROM mxaliases WHERE alias='%s' AND status='paid'");
  • Улучшены механизмы по отслеживанию пути сообщения через фильтры контента, обращение к которым производится через SMTP (например, обращение к сетевому сервису amavis-new через опцию content_filter). В частности, расширение протокола XCLIENT позволило при получении обработанного сообщения от фильтра контента, помещать в лог идентификатор сообщения в очереди, который использовался при передаче сообщения на сервер фильтрации;
  • Поддержка опции "smtpd_reject_footer", позволяющей указать блок текста, который будет добавлен к отвергнутым сервером запросам (SMTP-ответ "reject").


Отдельно сообщается, что корректирующие обновления с исправлением накопившихся ошибок для поддерживаемых веток Postfix 2.7, 2.6, 2.5 и 2.4 будут подготовлены по мере готовности. Поддержка ветки Postfix 2.4, выпущенной в 2007 году, будет прекращена в ближайшее время.




Вас также может заинтересовать:

После года разработки представлен релиз новой стабильной ветки почтового сервера Postfix - 2.9.0
Релиз почтового сервера Exim 4.73 с устранением уязвимостей
Релиз почтового сервера Exim 4.74 с устранением уязвимости
15.06.2010 Использование CommuniGate Pro как почтового сервера периметра для MS Exchange на GNU/Gentoo Linux
15.06.2010 Интеграция почтового сервера CommuniGate Pro(GNU/Gentoo Linux) c доменом Microsoft Active Directory
Релиз http-сервера lighttpd 1.4.29